Service Disruption - Cloudflare Global Outage

Incident Report for Sessionboard

Resolved

Cloudflare has largely restored their services, though they are still observing some regional instability.

We will continue to monitor the situation closely and will keep this page updated if any new impact arises.

Thank you for your patience throughout this incident.
Posted Nov 18, 2025 - 10:15 EST

Update

We are starting to see some services come back online following Cloudflare’s outage. However, not all functionality has fully recovered yet.

Our team continues to closely monitor Cloudflare’s status and overall system stability. We’ll provide updates as recovery progresses.

Thank you for your patience.
Posted Nov 18, 2025 - 09:39 EST

Monitoring

We’re currently experiencing a major service outage due to a widespread issue impacting Cloudflare, our network and edge infrastructure provider. This outage is affecting many services across the internet and as a result Sessionboard is temporarily unavailable. (Reference: https://www.cloudflarestatus.com/)

Our team is actively monitoring Cloudflare’s mitigation efforts and will restore full access to Sessionboard as soon as the upstream issue is resolved. They have found a fix are working on restoring systems.

We’ll continue sharing updates here as more information becomes available.

Thank you for your patience and understanding.
Posted Nov 18, 2025 - 08:37 EST
This incident affected: Web Application (Web Application (US), Web Application (EU)) and Public API (Public API (US), Public API (EU)).