[US] Upcoming maintenance on Wednesday, July 17th, 2025

Scheduled for Jul 17, 18:00 - 19:30 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 17, 2025 - 22:00 EDT

Scheduled

[US Customers] Sessionboard will enter maintenance mode starting from Wednesday, July 17, 2025 at 10PM EST / 7PM PST.

We expect this to take less than 90 minutes. No action is required by customers. During this time, the admin interface, portals and forms will be unavailable. Upon completion of the maintenance, we will update this status and immediately restore access.
Posted Jul 14, 2025 - 15:00 EDT
This scheduled maintenance affects: Web Application (Web Application (US)) and Public API (Public API (US)).