Cloudflare has fully restored their services, and Sessionboard is now operating normally. All previously impacted features have recovered as expected.
We’ve verified system stability on our side, and no further disruption is anticipated.
Thank you for your patience while this issue was resolved. If you continue to experience any problems, please reach out to our support team.
Posted Nov 18, 2025 - 11:25 EST
Monitoring
Cloudflare has mostly restored their services, but they are continuing to monitor some regions experiencing residual instability. As a result, a small number of users may still see intermittent issues within Sessionboard.
Our team is actively monitoring performance and stability while Cloudflare completes their recovery efforts. We will update this incident as we learn more or observe any changes.
Thank you for your patience.
Posted Nov 18, 2025 - 10:39 EST
Investigating
Cloudflare has mostly restored their services, but they are continuing to monitor some regions experiencing residual instability. As a result, a small number of users may still see intermittent issues within Sessionboard.
Posted Nov 18, 2025 - 10:39 EST
This incident affected: Web Application (Web Application (US), Web Application (EU)) and Public API (Public API (US), Public API (EU)).